Problem Definition:

When an end user connects to a CloudConnect Virtual Desktop from a Microsoft Windows client with multiple monitors, the virtual desktop is displayed only in a single monitor.

Cause:

By default, CloudConnect desktops launch with the Citrix Desktop Viewer (CDViewer.exe) enabled.This provides the user with the Desktop Toolbar feature, and the ability to toggle between the user’s client workstation and the virtual desktop.The Citrix Desktop Viewer and Desktop Toolbar are not compatible with multiple monitors.

Resolution:

Disable the Citrix Desktop Viewer on the user’s workstation computer by renaming the file “CDViewer.exe” to “CDViewer.exe.old” The file is located in the following directory on the client computer:

32 Bit Workstation:

C:\Program Files\Citrix\ICA Client\CDViewer.exe

64 Bit Workstation:

C:\Program Files (x86)\Citrix\ICA Client\CDViewer.exe

The Citrix Receiver will now operate in “Seamless Mode” where the virtual desktop is extended across all monitors connected to the client’s workstation.

Additional Information:

This setting applies to all users who connect to a CloudConnect Desktop from this workstation.When upgrading the version of Citrix Receiver, it will be necessary to repeat the above step to re-enable multiple monitor support.Note that The Desktop Toolbar is not compatible with this mode of operation.Users can use SHIFT + F2 to exit Seamless Mode.

Applies To:

Microsoft Windows Desktop and Server Operating Systems XP/2003 and later


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