Problem Definition:

You need to edit the Non-Administrators Policy on a Desktop Host. This may be necessary in order to loosen or strengthen security policies and/or the areas of the Desktop Host that Non-Administrators are able to access.

Cause:

CloudConnect uses two Local Policy Templates.The First is the standard Local Group Policy Objects (gpedit.msc), which allows you to modify Computer Settings and User Settings, which are applied to all users.The Second Template is the Non-Administrators Policy, which adds an additional layer of restrictions to Non-Administrator Users.The policies are bound to Desktop Hosts, so for mspCloud organizations, each organization will have its own set of policies.For Private Domain organizations, each desktop host will have its own set of policies.

Resolution:

You may Access and Edit the Non-Administrators Policy as follows:


Access the Desktop Host for the Organization you would like to modify using your “support” account. From the Start Menu or Run Dialogue Box choose type “mmc.exe”


In the Microsoft Management Console, choose “Add/Remove Snap-In:"


Select "Local Group Policy Object Editor," Click the "Add" button:


The Group Policy Object Selection Dialogue Box will now appear, select "Browse:"


Choose the “Users” Tab and then pick “Non-Administrators”


Click “Finish”


Next, Click “Okay”


You will now see “Local Computer\Non-Administrators Policy” at the Console Root. You may proceed to edit the policies which are bound to Non-Administrator Users (End Users) of the Desktop Host:

 

Additional Information:

The “Computer Configuration” node will not be visible in this policy as it is not applicable.

Applies To:

Microsoft Windows Server 2008 R2 Standard Remote Desktop Services

Microsoft Windows Server 2012 R2 Standard Remote Desktop Services

Citrix XenApp 6.x

Citrix XenApp 7.x