Problem Definition:

A User has inadvertently deleted or corrupted a file, multiple files and/or a folder or multiple folders residing on a Windows NTFS volume.

Cause:

Shadow Copies (if enabled) can be utilized to quickly and noninvasively restore files and or folders with a relatively recent and configurable Recovery Point Object (RPO).  Shadow Copies are a first line of defense against data loss or corruption.  Shadow Copies behave like a snapshot of a Windows NTFS volume, and these snapshots are taken periodically or according to a preconfigured schedule.

Resolution:

To restore a file or folder using Shadow Copies, access the Server or Desktop Host using your “support” account:


If the files or folders to be restored have not been completely deleted:

In this case, browse to the file or folder which needs to be restored. Right click on the file or folder and choose “Restore Previous Versions.”


If Shadow Copies are enabled, you will see a “Date Modified” column. Simply choose the point in time you would like to restore to, and then you may “Open,” “Copy,” or “Restore” from that point in time.

Open: Allows you to browse the contents of a folder to see what it looked like at that point in time. From this window, you may copy out the files or folders you would like to restore.


Copy: Allows you to copy and paste the entire folder and contents (as it existed at that time) to any new directory or drive in Windows. You may then access and move files or folders to their original or a new location.


Restore: (Not Recommended): Will automatically revert the entire file or folder to the point in time. Because this will overwrite the existing files or folders, this approach is not recommended.


If the files or folders to be restored have been completely deleted:

In this case, you will need to browse to a parent folder or drive, which contained the file or folder to be restored.Right click on the parent folder and choose “Restore Previous Versions.”Similar to the above procedure, you may now choose a point in time prior to the deletion of the files or folder to be restored.Choose “Open,” and browse to the files or folders that were deleted.You may now restore or copy out those files or folders to their original location or a new location of your choosing.

Additional Information:

In order to use the above procedure, shadow copies must be enabled in advance.  To enable Shadow Copies, please see CCT-201410101.If you are unable to restore from shadow copies, or do not have Shadow Copies enabled, please see CCT-201410111, or Open a Ticket with CloudConnect Technical Support to request Data Recovery from Nightly Backup.

Applies To:

Microsoft Windows Desktop Server 2008 R2 Standard

Citrix XenApp 6.5