Problem Definition:

Nightly Backup may not meet your organization’s Recovery Point Objective (RPO) and Recovery Time Objective (RTO) in the event files or folders are corrupted or deleted by an end user.

Cause:

Shadow Copies can snapshot a Windows Volume at a frequency configurable to meet your organization’s needs, and can also allow you to have full control over restoring files and folders. Restoring files and folders is nearly instant with Shadow Copies.

Resolution:

To enable and configure Shadow Copies, access the desktop host or server you would like to protect using your “support” account.


From the Start Menu choose “Computer,” then right click on any drive hosted on the system you are logged into and select “Configure Shadow Copies” (Note that you cannot configure shadow copies on a mapped drive, this must be done on the system hosting the mapped drive contents).

 

In the Shadow Copies Dialogue Box, right select the Volumes you wish to protect, and choose “Enable.”  Once enabled, shadow copies will operate using the standard settings of a 4 GB storage area limit (i.e. 4GB of deltas).

 

You can configure Shadow Copies Settings for each Volume, by choosing the “Settings” button with the respective Volume highlighted.Use the “Settings” Dialogue Box to set the storage limit (amount of space used on the drive for shadow copy deltas), and you can also customize the schedule using the “Schedule” button.  This allows you to set the frequency with which snapshots are taken.Snapshots are maintained until the storage area runs out of space, at which point Windows removes the oldest shadow copies to free up space.


Additional Information:

Shadow Copies are a great way to supplement the Nightly Backup Service. Because Nightly Backup also captures configured Shadow Copy storage, use the Shadow Copy feature to take snapshots frequently (i.e. every hour or few hours), and limit the storage area to a size that retains the Shadow Copy trail for no more than one week.


To restore files and folders from Shadow Copies, see CloudConnect KB Article CCT-201410099 – How to restore files and folders from Shadow Copies.

Applies To:

Microsoft Windows Desktop Server 2008 R2 Standard

Citrix XenApp 6.5