Problem Definition:
When attempting to launch a CloudConnect Desktop using a Mozilla Firefox Web Browser with dds.cloudconnect.net (or other Citrix Web Interface-based branded URL), the desktop fails to launch.The Play Button spins when clicked, but nothing else happens. Citrix Receiver is also properly installed.
Cause:
By default, Firefox is blocks websites from loading the ICA file into Citrix Receiver. As a result, the CloudConnect Desktop Viewer does not even launch.
Resolution:
Click the Plugin Icon to the left of the address bar. Choose, “Allow and Remember.”
Restart Mozilla Firefox.
Additional Information:
This KB Article does not apply to desktops launched via Citrix StoreFront Server and Citrix NetScaler. For additional information on Firefox plugin activation, see:
https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins?as=u&utm_source=inproduct
Alternatively, you may add the URL dds.cloudconnect.net to your Firefox Trusted Sites.
Applies To:
Mozilla Firefox
Citrix Receiver 3.0 and above
Citrix Web Interface