Problem Definition:

After fixing a corrupt user profile, or migrating user data to a new user profile, the following symptoms may appear after accessing the User’s new Desktop:

A black screen or hang on “Applying User Settings” when accessing the user’s desktop.  This eventually resolves and the Desktop appears.


The following error message may be displayed when accessing Windows Explorer:

 

Cause:

 The Microsoft Windows HKEY_CURRENT_USER Registry Hive is corrupt.

Resolution:

Instruct the user to logoff from their Desktop, and verify that the user is logged off from the task manager.


Using your "support" account, access the desktop host where the user is working, and Open Windows Explorer.  In the "Organize" menu in the tope left hand corner, choose "Folder and search Options."


In the Folder Options Dialogue box, select "Show Hidden Files," and clear the check box for both "Hide Extensions for Known File Types," and "Hide Protected Operating System Files."  Click Yes to the Warning Message that appears.


Navigate to:

If the Desktop Host is using the Secure Image, the Location is:

B:\users\%username%\AppData\Local\Microsoft\Windows\

If the Desktop Host is using the Standard Image, the Location is:

C:\users\%username%\AppData\Local\Microsoft\Windows\

Make a backup of all files beginning with “UsrClass.dat” then delete all files beginning with “UsrClass.dat…”


Have the user log back on, the UsrClass.dat files are recreated

Additional Information:

You may need to reconfigure certain registry settings located in HKCU depending on a program’s dependency on these settings

Applies To:

Citrix XenApp 6.5

Microsoft Windows Server 2008 R2 Standard