Problem Definition:
Users report they are prompted to activate Microsoft Office 2016 Applications following an upgrade from 2010 or 2013. The edition of Microsoft Office is Microsoft Office Standard or Professional Plus.
Cause:
Some older CloudConnect Desktop Host Images originally carried the KMS activation server address in the registry. If this registry entry is not removed prior to upgrading, it is carried forward and immune from removal when applying the ospp.vbs /remhst command.
Resolution:
Using your support account, access the customer organization’s Desktop Host for the organization(s) experiencing the activation error
1) From vCloud Director, locate the CloudConnect Utilities Catalog in "My Organization's Catalogs." Right Click on the Catalog and choose "sync." This will acquire the latest configuration utility versions Published by CloudConnect.
2) Once the Catalog synchronization is complete, right click on the affected VM and choose “Insert CD/DVD from Catalog.” Insert the KMSClientActivationUtility.
3) Logon to the virtual machine console as administrator, and run the KMSClientActivationUtility.exe from the DVD drive.
4) If activation failure persists, send the KMS Client Activation log file to CloudConnect Technical Support. The log files are located at C:\CloudConnect\KMSClientActivationUtility
Important! This Utility requires Windows Management Framework Version 4 and newer. If you are running Windows Server 2008 R2, verify you have at least Windows Management Framework Version 4 installed before running this script. If you do not, download and install the Management Framework from the Microsoft Website here: https://www.microsoft.com/en-us/download/details.aspx?id=40855 .
Additional Information:
This issue occurs when the KMS client entries exist in the registry. These entries override with DNS-based volume license activation, which was introduced by CloudConnect in early 2016.
Applies To:
Citrix XenApp 6.5 with Microsoft Office 2016.
Citrix XenApp 7.7 with Microsoft Office 2016.