Problem Definition:
When attempting to connect to a CloudConnect Virtual Desktop using Citrix Receiver StoreFront from another Virtual Desktop, or from a corporate network with DNS servers running on CloudConnect, the following errors may be displayed:
Note: You are still able to successfully connect using Citrix Receiver for Web.
Cause:
You are attempting to access a CloudConnect virtual desktop using the Citrix StoreFront protocols form a device where one of the following is true:
1) Your device is using DNS with conditional forwarders for portal.cloudconnect.net and gateway.cloudconnect.net.
2) Your device you are connecting from has the Citrix Virtual Desktop or Citrix Virtual Delivery Agent installed.
Resolution:
This behavior is by design and is due to a Citrix software limitation as applied to the CloudConnect architecture. To work around this issue, use Citrix Receiver for Web in this scenario.
Additional Information:
CloudConnect will update this article when or if this feature is available.
Applies To:
Citrix XenApp
Microsoft Windows