Problem Definition:
The Citrix Desktop Service fails to start after upgrading to XenApp 7.11 (DesktopConfig Version 3.5.0 or newer). When Attempting to launch a Virtual Desktop, users get "Cannot Start Desktop" message in the Citrix StoreFront. The following errors are logged in the Event Viewer on the upgraded Citrix Server:
Event ID 1026
Application BrokerAgent.exe
Framework Version v4.0.30319
Description: The process was terminated due to an unhandled exception
Event ID 1000
Faulting Application name: BrokerAgent.exe, version 7.11.0.11
Faulting module name: KERNELBASE.dll
Exception code:0xe0434352
Cause:
The root cause is under investigation. To work around this issue, follow the Resolution below.
Resolution:
Uninstall the Citrix Monitor Service VDA Plugin. This must be done from a PowerShell console as this service is not specifically listed in the Programs and Features. From the Virtual Machine console of the affected Citrix Service, open PowerShell and type the following:
$MonitorPlugin = Get-WmiObject win32_product | where {$_.Name -eq "Citrix Monitor Service Vda Plugin"} </ENTER>
$MonitorPlugin.Uninstall() </ENTER>
The Citrix Desktop Service will automatically start after removal of the Monitor Plugin. Restart the Citrix Server. Users will be able to logon after restart.
Additional Information:
CloudConnect will provide additional guidance once the root cause has been determined.
Applies To:
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2012 R2
Microsoft Windows Server 2016
Citrix XenApp 7.11
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