Problem Definition:


When trying to access your Citrix Desktop from a mobile Apple device such as an iPhone or iPad, you might experience the error "hdxsdk error domain_session error 8". 


Cause:


Out-of-date application or operating system. The Citrix Receiver for iPhone/iPad is a deprecated application that has been replaced by Citrix Workspace.


Resolution:


1) Ensure that the operating system of your Apple device is iOS 10 or later. If it is not, you must upgrade your operating system.


2) Ensure you are NOT using the application "Citrix Receiver", but using the updated and maintained application Citrix Workspace. You can find a link to the AppStore download page here.


Additional Detalis:


To learn more about how CloudConnect's Citrix solution empowers businesses users just like you, you can click here to download our latest Citrix whitepaper.